Please register to receive Datix v14.0


If you would like a copy of Version 12.3, please contact support@datix.co.uk.

We are asking you to register for this release because a new licence key is required for DatixWeb v14.0.

The new licence key will be sent to the email address with which you registered. The link to the files and upgrade instructions will be sent separately.

There are also some technology requirements which you and your IT department must be aware of. Full details will be in the release documentation.

  • Requires PHP 5.6.11
  • Supports Internet Explorer version 7,8,9,10 & 11
  • Supports SQL Server 2008, 2008R2, 2012, 201
  • Supports Windows Server 2008 with IIS 7.0, Windows Server 2008R2 with IIS 7.5, Windows Server 2012 with IIS 8, Windows Server 2012 with IIS 8.5

If your organisation does not have DatixWeb installed and only uses Datix Rich Client, please register to receive the link to the files and upgrade instructions.

Register now by emailing support@datix.co.uk

Find out more information about the course and requirements.